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1. Introduction

A web service provides functionality to other applications, without the constraint that the service runs on the same machine as the application that uses (“consumes”) it. The main benefit is that large and complex systems can be divided into smaller specialized modules (web services), distributed across the network, running concurrently and being invoked only when needed. Another advantage of the web services is that they can be written in different programming languages and may run on various platforms. In order for such a heterogeneous architecture to be functional, several standards have been defined. Thus, web services communicate with other programs through SOAP (standard web protocol), the provided interface is described using WSDL (Web Services Description Language); web services can be found by potential users with UDDI (Universal Discovery, Description and Integration) – a protocol for updating and querying web service information repositories.

The following sections will be referring to the lifecycle of a web service, implemented with Visual Studio 2005 (ASP.NET 2.0 technology).

2. Building a Web Service

The starting point for a web service can be the source code of any existing .NET application. Converting it to a web service involves the following operations:

· Adding a reference to the System.Web.Services library module

· Annotating the exposed methods with the attribute: WebMethod
· It is not necessary, but it may be useful to: 

· Derive the class which should become a web service from System.Web.Services.WebService
· Apply a WebService attribute to the class declaration. 

This approach is not recommended, since all web services specific information can also be generated automatically.

Another way to build a web service is to create it as a web application. This way, the above mentioned actions and other useful ones (e.g. generating asmx file) will be performed automatically. In this case, only the following steps are needed:

1. Creating a new Web Application (choose File → New → Web Site)

2. Choosing the ASP.NET Web Service template

3. A web service class file will be automatically generated (with all specific notations described above); all that remains to be done – since it cannot be automated – is to fill in the source code for the web service class: the web methods (with the WebMethod attribute, as suggested in the “Hello World” method example, which is also automatically included in the web service).

An alternative to step 2 would be creating a web service as part of a web application:

· Choosing the Empty Web Site template

· Adding a web service (right-click on the web site in the Solution Explorer, choose Add New Item → Web Service and specify the web service name, e.g. Webserv.asmx)

After these steps, the web service code can be compiled (F6) as any other project. 

The web service project (or web application project) has the following structure: 

· The App_Data folder holds database files 

· The App_Code folder holds the source code files

· The asmx file – acts as the web service URL (when navigating to this file in a browser, a user-friendly page is displayed, showing the interface of the web service).

To illustrate the automatically generated code and the way functionality can be added, the source code for a simple web service class is given below:

using System;

using System.Web;

using System.Collections;

using System.Web.Services;

using System.Web.Services.Protocols;

/// <summary>

/// Summary description for Webserv

/// </summary>

[WebService(Namespace = "http://tempuri.org/")]

[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]

public class Webserv : System.Web.Services.WebService {

    public Webserv () {

        //Uncomment the following line if using designed components 

        //InitializeComponent(); 

    }

    [WebMethod]

    public string HelloWorld() {

        return "Hello World";

    }

    [WebMethod]

    public int Add(int m, int n)

    {

        return m + n;

    }

}
Listing 1 Simple web service class source code (Webserv.cs)

The Add method (in bold italics) is a simple functionality example; all the rest of the code was automatically generated (including the HelloWorld method, as a model for defining other web methods). Of course, the HelloWorld method will be deleted after the methods that implement the real functionality of the web service are defined.

3. Testing a Web Service

A web service can be tested as soon as it is created, without even writing a client or publishing the web service. This is possible because there is a built-in web server in .NET. It chooses a different port number each time it is run, but this is not important for testing, so it is not a problem. When “running” (F5) a web service, the test page will be opened in the browser.

The default web page created by .NET uses reflection to display the available web methods; they are represented as links, so that they can be tested individually by entering their parameters and clicking the Invoke button – the result will be displayed in XML.

In Fig. 1, the web page for testing a particular web method (web page accessed from the main test page, by clicking the link corresponding to the web method) is displayed.
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Fig. 1 Web page for web method testing

The page allows entering parameters for the Add method, and checking the XML result obtained by clicking the Invoke button.

4. Deploying a Web Service

In order to have access to a web service, it has to be made available over the Internet. A commonly used solution to this problem is to create a virtual directory in IIS (Internet Information Services) – included on Windows OS CD.

A virtual directory is created by performing the following steps:

· Open IIS Manager (Settings → Control Panel → Administrative Tools → IIS)

· Right-click on Default Web Site and choose New → Virtual Directory
· Follow the steps of the Virtual Directory Creation Wizard:

· Give an alias (short name)

· Provide the path to a directory containing the information about the web service (the asmx file and App_Code folder are mandatory)

· Set access permissions for the virtual directory (usually, the default permissions are enough: “Read” and “Run scripts”)

This way, the web service will be available through the alias of the virtual directory that contains it. For example, if the alias is WS and the asmx file is Webserv.asmx, then the web service is accessed by http://computername/WS/Webserv.asmx (computername can be substituted to localhost if the web service resides on the local computer).

5. Consuming a Web Service

Web services are designed for machine consumption. They are useless if no other application needs the operations they provide. In the following paragraphs, the focus is on web applications that use web services.

5.1.  Building a web client

The steps to build a web client are:

· Creating a new Web Application (choose File → New → Web Site)

· Choosing the ASP.NET Web Site template

· Adding a reference to the Web Service that will be consumed (right click on the project in the Solution Explorer and choose Add Web Reference): provide URL of web service (http://computername/WS/Webserv.asmx in the previous example), or search for web services on the local computer or on the network (UDDI).

After these steps, the structure of the web client will be the following:

· The App_Data folder holds database files

· The App_Code folder holds the source code files (optional, created only when the first source code file is added to the project)

· The App_WebReferences folder contains a subfolder for each web reference, and each web reference folder holds three files. For example, in case of Webserv.asmx, the files will be:

· Webserv.disco (discovery document)

· Webserv.discomap (provides links to web service contract and discovery document)

· Webserv.wsdl (web service contract)

· The Default.aspx and Default.aspx.cs files (web page and code-behind page) 

· The web.config file (configuration settings)

A client example for the previously created and deployed simple web service (with the Add method) is a web application that computes the sum of two integers:
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Fig. 2 Web application – client for simple web service

The web page is displayed when running the web application (F5). The web service Add method is invoked when the “=” button is clicked and the result is shown in the text box placed after the button.

5.2.  Issuing requests to Web Services (synchronous calls)

Web services can be instantiated just like they were ordinary classes in the namespace given by the web reference folder name (Solution Explorer). In order to invoke an operation offered by a web service, the corresponding method of the web service instance will be called. However, even though they look like ordinary method calls, web service requests must be handled with care – in this case, the function call is packaged into a SOAP message and marshaled across the Internet via the HTTP protocol. Because of the inherent nature of the Internet, performance of the remote call to the web service can vary from one call to the next; anyway, it takes a larger amount of time to call a web method than to call a method in a local component. Thus, the way web developers design their applications has a significant impact on how users will perceive the performance of the application.

 In order to better illustrate the usage of a web service, a fragment of the source code in the code-behind page of the client is shown below (the web reference folder is WebService).

    protected void Button1_Click(object sender, EventArgs e)

    {

        int n1 = Int32.Parse(TextBox1.Text);

        int n2 = Int32.Parse(TextBox2.Text);

        WebService.Webserv ws = new WebService.Webserv();

        int result = ws.Add(n1, n2);

        TextBox3.Text = result.ToString();

    }

Listing 2 Web service synchronous request (method call)

5.3.  Asynchronous requests

For performance reasons, sometimes it is useful to continue executing the caller thread, while the request sent to the web service is handled concurrently; the caller thread is notified when the web service operation finishes. This way, the results can be processed when available, without waiting for them. These are called asynchronous requests and there are two ways of issuing them in an ASP.NET page.

Both alternatives for performing asynchronous requests imply defining a callback routine to be executed when the requested operation completes. The methods, events and delegates necessary for asynchronous requests are automatically generated. They can be viewed by explicitly generating a source code file called a proxy class (Webserv.cs, having the name of the web service). In order to generate the proxy class, if the web service URL is known, the wsdl.exe command-line tool is used. For the simple web service example, the command to execute in the command prompt window is:



wsdl http://localhost/WS/Webserv.asmx

(The wsdl.exe file can be found in the .NET Framework directory, which is typically in a path similar to C:\Program Files\Microsoft Visual Studio 2005\SDK\v2.0\Bin)

The first way of issuing asynchronous calls to a web service is by using the method with the Async suffix and the event attached to operation completion. Assuming the previously generated proxy class (Webserv.cs) is included in the web client (in the App_Code folder), the code for issuing an asynchronous Add operation in the web client example is the following:

public partial class _Default : System.Web.UI.Page 

{

    Webserv ws = new Webserv();

    protected void Page_Load(object sender, EventArgs e)

    {

        ws.AddCompleted += new AddCompletedEventHandler(ws_AddCompleted);

    }

    void ws_AddCompleted(object sender, AddCompletedEventArgs e)

    {

        int result = e.Result;

        TextBox3.Text = result.ToString();

    }

    protected void Button1_Click(object sender, EventArgs e)

    {

        int n1 = Int32.Parse(TextBox1.Text);

        int n2 = Int32.Parse(TextBox2.Text);

        ws.AddAsync(n1, n2);  

    }

}

Listing 3 Web service asynchronous request

The important aspects are displayed in bold. There is an event handler (callback routine), ws_AddCompleted, which updates the contents of the result text box. When the web page is loaded, the event handler is attached to the AddCompleted event. Instead of getting the result by calling the Add operation (meaning that the function call does not return until the result is ready), in this case the caller thread does not wait for the operation to end, it just initiates the asynchronous request (by calling the AddAsync method).

The second possibility is to make use of the IAsyncResult interface and two methods in the proxy class: BeginAdd and EndAdd. The code for initiating the request is shown below:
IAsyncResult a = ws.BeginAdd(n1, n2, new AsyncCallback(MyCallback), asyncState);

Listing 4-1 Web service asynchronous request (alternative)
The callback routine must have the prototype given by the AsyncCallback delegate:

    private void MyCallback(IAsyncResult AsyncResult)

    {

        int result = ws.EndAdd(AsyncResult);

        TextBox3.Text = result.ToString();

    }

Listing 4-2 Web service asynchronous request (alternative)
5.4.  Web Service Contract

The contract of the web service is its interface – what it offers to clients. There is a standard description language (WSDL), so that a client, even built in a different technology, can successfully communicate with the web service.

As mentioned earlier, a wsdl file is generated when adding a web reference. WSDL documents consist of five main elements:

· three abstract items, which define the interface (methods, parameters, properties)

· types

· message

· portType

· two concrete items, which define the protocol (SOAP over HTTP) and address information (URL):

· binding

· port

Flexibility is increased by separation of the interface definition from location and protocol information.

As an example, the Add method in the simple web service is defined throughout the WSDL document having elements defined in different sections.
In the types section, data types are defined – the <types> element is an XML Schema. Every message (for web method description) is defined as a complex type, including method name, parameters and their data types. For each method, two complex types are defined:
· one complex type containing method parameters and their types (Add)

· one complex type for method return type (AddResponse)

<wsdl:types>

…
<s:element name="Add">
<s:complexType>

<s:sequence>

 <s:element minOccurs="1" maxOccurs="1" name="m" type="s:int" />

         <s:element minOccurs="1" maxOccurs="1" name="n" type="s:int" />

       </s:sequence>

     </s:complexType>

</s:element>

   <s:element name="AddResponse">

     <s:complexType>

       <s:sequence>

         <s:element minOccurs="1" maxOccurs="1" name="AddResult" type="s:int" />

         </s:sequence>

       </s:complexType>

  </s:element>

  …
</wsdl:types>

Listing 5-1 WSDL document – defining a web method: types section

The message section presents the messages exchanged between the client and the web service in order to perform a method call (the client sends a request message and the web service sends a different message with the result when the operation finishes).
<wsdl:message name="AddSoapIn">

  <wsdl:part name="parameters" element="tns:Add" />

</wsdl:message>

<wsdl:message name="AddSoapOut">

  <wsdl:part name="parameters" element="tns:AddResponse" />

</wsdl:message>

Listing 5-2 WSDL document – defining a web method: message section

In the portType section, input and output messages are grouped into operations having the name of the methods:
<wsdl:portType name="WebservSoap">

  …

    <wsdl:operation name="Add">

     
<wsdl:input message="tns:AddSoapIn" />

<wsdl:output message="tns:AddSoapOut" />

    </wsdl:operation>

  …

</wsdl:portType>

Listing 5-3 WSDL document – defining a web method: portType section

6. Conclusion

In Visual Studio 2005, most steps of web service creation, deployment and consumption are automated, so the developer can better focus on those critical design and code issues that cannot be automated (performance of the functionality offered by the web service).
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